Page 2 of 2 FirstFirst 12
Results 11 to 11 of 11

Thread: 348 ac snag

  1. #11
    Nosevi's Avatar
    Nosevi is offline There's an outside too? Where? Super Moderator
    Join Date
    Jun 2011
    Location
    Lincolnshire
    Name
    Nos
    Posts
    10,564

    Default

    Just to round off this thread, I went and bought a pressure gauge and as I suspected, zero pressure in the system. Added some R134a refrigerant (my system was converted a few years ago) and immediately the compressor engaged and there was a click from the compressor clutch on selecting AC, but showed almost no pressure. Put some more in and now seems to work fine.

    System seems to hold pressure fine so no leaks. Seems like they simply forgot to re-gas the AC after the engine out. Annoying, particularly as they charged me for a re-gas over and above the cost of the service. Few months ago now so tough to prove it hasn’t somehow ALL leaked out. Kind of doubt it though.
    Last edited by Nosevi; 28-08-2018 at 12:57 PM.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. 348 HVAC snag
    By Nosevi in forum Technical Q & A
    Replies: 14
    Last Post: 01-05-2016, 11:10 AM
  2. Replies: 0
    Last Post: 04-06-2014, 10:08 AM
  3. AC snag
    By Nosevi in forum Galleries and Members Cars
    Replies: 15
    Last Post: 19-05-2014, 10:46 AM
  4. 348 minor engine snag
    By Nosevi in forum Technical Q & A
    Replies: 20
    Last Post: 08-08-2012, 11:57 AM
  5. Replies: 24
    Last Post: 19-02-2006, 05:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •